Feature - Support Email Servers Require TLS 1.2 for SMTP Connection

Release Date: 08/26/2021
Changed: 09/02/21 
Version: 8.5 Only

Note: *** The flag SMTPUseTLS1.2 is deprecated because Elliott 8.5 will now (starting 9/2/2021) support all TLS versions including SSL2, TLS1.0, TLS1.1 and TLS1.2 automatically and therefore, there's no need for this flag ***

A new flag is being added to <ElliottRoot>\Bin85\EL850.CFG file to support Email Servers Require TLS 1.2 SMTP Connection. See the following sample screen for the new flag SMTPUseTLS1.2:


You can also update this flag by running the configuration utility from <ElliottRoot>\Bin85\EL850CF.EXE. See sample screen below:


Currently, most email servers support SSL security layer TLS 1.1 and TLS 1.2. By default, Elliott v8.5 uses TLS 1.1 (when you select Enable SSL/TLS). If, however, your email server requires TLS 1.2, select this option to make v8.5 use TLS 1.2 instead of TLS 1.1. Note that this selection applies to all of your email servers, so they will all use TLS 1.1 or all use TLS 1.2.

Note this feature is applicable only to Elliott 8.5.  The future Elliott versions (e.g., 8.6) will automatically support the highest level of TLS that the email servers can support.  This includes TLS 1.0, 1.1, 1.2 or the upcoming 1.3. Hence, this flag is not needed in Elliott version 8.6 and after.


EMK/JEG

Feedback and Knowledge Base